lunes, 26 de septiembre de 2011

Squid Transparente + cache

Como parte de los articulos, que tenia pendiente escribir y que he tocado en mis 2 últimos cursos, llego el momento de al fin documentar la instalación básica de un proxy transparente en squid y con chache para reducir un poco nuestras consultas...

El proceso, que ahora documento, lo aplique en Fedora 15 (por motivos de trabajo migre mi servidor a esta plataforma) pero aplica a otras distribuciones en general.

Conocido es dentro de la comunidad, que el archivo de configuración de Squid, es uno de los mas documentados... En su gran cantidad de lineas, se hallan todas las explicaciones que nos indican que podemos hacer -Debo aclarar que para mi sorpresa RHEL cambio este archivo y presenta ahora una versión muy corta- para configurar nuestro proxy.

Ahora, la realidad es que aunque tiene un montón de lineas, se puede tener funcionando un squid con modificar solamente un par de parámetros...

El primer paso sencillamente es instalarlo, para ello en distros .Deb ejecutamos:

# aptitude install bind

Mientras que en otras RHEL:

# yum -y install bind

Ya instalado lo que tenemos que hacer es modificar los parámetros básicos en el archivo de configuración el cual se encuentra en /etc/squid/squid.conf

Dentro de este archivo, basicamente, lo que debemos hacer es:

  • Agregar el la parte de ACL una entrada para nuestra red local; la linea queda algo como esto: acl redcurso1 src 192.168.2.0/24
  • Agregar una regla para permitir la salida de nuestra red a internet, para ello, en el segmento de reglas del archivo agregamos algo así: http_access allow redcurso1
  • Ubicamos ahora, la configuración del puerto que usara squid, dejando la linea así: http_port 192.168.2.1:3128 transparent
  • Agregamos el nombre del host: visible_hostname none
  • Descomentamos y adaptamos la linea para el cache: cache_dir ufs /var/spool/squid 100 16 256
En una versión resumida (Sacada de mi configuración en Fedora), el archivo queda asi:

#
# Recommended minimum configuration:
#
acl manager proto cache_object
acl localhost src 127.0.0.1/32
acl localhost src ::1/128
acl to_localhost dst 127.0.0.0/8 0.0.0.0/32
acl to_localhost dst ::1/128

# Example rule allowing access from your local networks.
# Adapt to list your (internal) IP networks from where browsing
# should be allowed
acl localnet src 10.0.0.0/8    # RFC1918 possible internal network
acl localnet src 172.16.0.0/12    # RFC1918 possible internal network
acl localnet src 192.168.0.0/16    # RFC1918 possible internal network
acl localnet src fc00::/7   # RFC 4193 local private network range
acl localnet src fe80::/10  # RFC 4291 link-local (directly plugged) machines

acl SSL_ports port 443
acl Safe_ports port 80        # http
acl Safe_ports port 21        # ftp
acl Safe_ports port 443        # https
acl Safe_ports port 70        # gopher
acl Safe_ports port 210        # wais
acl Safe_ports port 1025-65535    # unregistered ports
acl Safe_ports port 280        # http-mgmt
acl Safe_ports port 488        # gss-http
acl Safe_ports port 591        # filemaker
acl Safe_ports port 777        # multiling http
acl CONNECT method CONNECT
acl redcurso1 src 192.168.2.0/24

#
# Recommended minimum Access Permission configuration:
#
# Only allow cachemgr access from localhost
http_access allow manager localhost
http_access deny manager

# Deny requests to certain unsafe ports
http_access deny !Safe_ports

# Deny CONNECT to other than secure SSL ports
http_access deny CONNECT !SSL_ports

# We strongly recommend the following be uncommented to protect innocent
# web applications running on the proxy server who think the only
# one who can access services on "localhost" is a local user
#http_access deny to_localhost

#
# INSERT YOUR OWN RULE(S) HERE TO ALLOW ACCESS FROM YOUR CLIENTS
#
http_access allow redcurso1

# Example rule allowing access from your local networks.
# Adapt localnet in the ACL section to list your (internal) IP networks
# from where browsing should be allowed
http_access allow localnet
http_access allow localhost

# And finally deny all other access to this proxy
http_access deny all

# Squid normally listens to port 3128
http_port 192.168.2.1:3128 transparent

# We recommend you to use at least the following line.
hierarchy_stoplist cgi-bin ?

# Uncomment and adjust the following to add a disk cache directory.

cache_dir ufs /var/spool/squid 100 16 256

# Leave coredumps in the first cache dir
coredump_dir /var/spool/squid

# Add any of your own refresh_pattern entries above these.
refresh_pattern ^ftp:        1440    20%    10080
refresh_pattern ^gopher:    1440    0%    1440
refresh_pattern -i (/cgi-bin/|\?) 0    0%    0
refresh_pattern .        0    20%    4320
visible_hostname none


Como hemos definido un proxy transparente, es necesario aplicar las correspondientes reglas de iptables, para ello, lo que haremos sera crear un pequeño scrip como el que sigue:

#!/bin/sh

# eth0 = internet
# eth2 = red Local

#----Limpiamos todas las reglas
iptables -F
iptables -X
iptables -Z
iptables -t nat -F
#----Damos inet a la LAN
iptables -t nat -A POSTROUTING -s 192.168.2.0/24 -o eth0 -j MASQUERADE
echo 1 > /proc/sys/net/ipv4/ip_forward
#----Politicas por defecto ACCEPT
iptables -P OUTPUT ACCEPT
iptables -P INPUT ACCEPT
iptables -P FORWARD ACCEPT

#Proxy transparente
iptables -t nat -A PREROUTING -i eth2 -p tcp --dport 80 -j REDIRECT --to-port 3128

Ejecutamos, el scrip y reiniciamos bind y listo.... A disfrutar de nuestro nuevo proxy...

sábado, 24 de septiembre de 2011

VirtualBox en RHEL v6

En un curso que dicte, hace una par de días junto con Richard Zambrano (uno de los participantes), compilamos los pasos para la instalación de VirtualBox en RHEL; Este contenido, lo probamos con total éxito en Centos 6.0 y ahora lo coloco a disposición de todos...

Paso  1: descargar repositorio VirtualBox:

Para el caso centos este paso queda:

wget http://download.virtualbox.org/virtualbox/rpm/rhel/virtualbox.repo -O /etc/yum.repos.d/virtualbox.repo

Ahora, si es Fedora -por ejemplo:

wget http://download.virtualbox.org/virtualbox/rpm/fedora/virtualbox.repo -O /etc/yum.repos.d/virtualbox.repo

Paso 2: instalar virtualbox, ejecutando:

yum - y install VirtualBox-4.1.i686

Alternativamente, podemos bajar el rpm de la pagina de virtual box y ejecutar para instalarlo:

rpm -Uvh VirtualBox-4.1-4.1.2_73507_rhel6-1.i686.rpm

VirtualBox requiere algunas dependencias que hay que instalar por separado, así que ejecutamos:

yum -y install kernel-devel kernel-headers dkms

Ahora, es necesario en algunos casos compilar el los modulos del kernel para el driver de virtualbox, para ello corregiremos la locacion de las fuentes y posteriormente la compilación para virtual box:

export KERN_DIR=/usr/src/kernels/2.6.32-71.29.1.el6.i686/

/etc/init.d/vboxdrv setup

Probamos los modulos y  si no da error entonces estamos listos para usar VirtualBox:

modprobe vboxdrv

Mejorar nuestros Repositorios RHEL 6 (Fedora 15)

rpm -Uvh rpmforge-release-0.5.2-2.el6.rf.i686.rpmCuando estamos usando una versión RHEL de Linux, siempre viene bien agregar la mayor cantidad de repositorios fuentes, para así aumentar el abanico de paquetes disponibles para instalar. Es muy normal, para aquellos que venimos de distribuciones grandes -como es mi caso con debian en la cual encontramos casi todo disponible en repositorios, que al hacer un search nos sintamos limitados con los resultados (debido sobre todo a lo que estamos acostumbrados), es por esa razon que nos viene bien activar en nuestros equipos la mayor cantida de repos posibles.

Todo lo que explicare a continuación esta probado para Fedora 15, pero aplica a distribuciónes RHEL v6. por igual...

Paso 1; El Repositorio FORGE:

Descargamos el RPM del repositorio:

wget http://pkgs.repoforge.org/rpmforge-release/rpmforge-release-0.5.2-2.el6.rf.i686.rpm

Instalamos el paquete ejecutando:
rpm -Uvh rpmforge-release-0.5.2-2.el6.rf.i686.rpm
Paso 2; El Repositorio de Fusion:

* Free:

wget http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm

Instalamos el paquete ejecutando:

rpm -Uvh rpmfusion-free-release-stable.noarch.rpm

* Non-Free:

wget http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm

Instalamos ejecutando:

rpm -Uvh rpmfusion-nonfree-release-stable.noarch.rpm

Paso 3; El Repositorio de Virtual Box:

Para Fedora Ejecutamos:

wget http://download.virtualbox.org/virtualbox/rpm/fedora/virtualbox.repo -O /etc/yum.repos.d/virtualbox.repo

En el caso de Centos seria:

wget http://download.virtualbox.org/virtualbox/rpm/rhel/virtualbox.repo -O /etc/yum.repos.d/virtualbox.repo



martes, 23 de agosto de 2011

Compartiendo internet en la red con moden USB

Compartir nuestra conexión es casi mas que solo una necesidad, dado que actualmente, es muy común encontrar que en una misma casa se tienen varias computadoras; incluso, nosotros mismos  los geek's fanaticos a los gadget's muy seguramente tenemos un PC de escritorio, un Portátil, un Teléfono con Wi-Fi, iPod, iPad, y multitud de otros dispositivos con capacidad para navegar en internet -a fin de cuentas, si de nosotros dependiera hasta la ducha tendría esta habilidad-.


Ahora bien, cada dia son mas populares los modems USB para internet, nos brindan buenos anchos de banda (si claro depende de donde estemos, que compañia usemos y nuestro propio plan de datos)y la posibilidad de tener una conexion que nos siga a todos lados... Pero estos dispositivos tambien nos plantean una pregunta: ¿Comó comparto mi conexion entre mis equipos? ¿Comó llevo esa conexion a mi wi-fi?

Soluciones a estas interrogantes, hay muchas, cada una mas compleja que la anterior... Yo hoy acá planteare una relativamente sencilla para compartir nuestra conexión a internet.

Lo que haremos sera muy sencillo, emplearemos un sencillo Script, que le diga a nuestra maquina servidor (la que tenga instalada el modem y se conecte a internet) que redireccione todo el trafico de salida que reciba por la interfaz cableada a la interfaz PPP (la que usan los modem USB).


Posteriormente, configuraremos manualmente la dirección Ip del cliente y el servidor y listo, tendremos todo funcionando y nuestra conexión compartida, asi que manos a la obra:

El Servidor:

Aca no hay mucho trabajo que hacer, es pre-requisito, que el modem ya este instalado y funcionando en nuestro equipo (basta casi siempre con instalar network-manager , network-manager-gnome -si usamos este entorno de escritorio- y alternativamente wvdial).

Teniendo el USB configurado lo que debemos es crear un script con el contenido que se detalla a continuación:

#!/bin/bash

# Script para compartir internet entre un ban y la red cableada
# Carlos J. Castillo N
# castilloc185@gmail.com
# Dr4g0nkn1ght

# Se activa el reenvio de paquetes

clear
echo "Activando la compartición de internet con BAN"
echo "Por favor espere"
echo "Activando el forward (reenvío de paquetes)"
echo 1 > /proc/sys/net/ipv4/ip_forward
echo "Reenvío de paquetes activo"

# Borramos reglas anteriores de iptables
echo "Borrando las reglas de Iptables Anteriores"
iptables -F
iptables -X
iptables -Z
iptables -t nat -F

echo "Reglas borradas, continuando con las iptables..."
echo "Activando el nat"
#Activando NAT en ppp0
iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

echo "todo se ha configurado correctamente"
echo "Disfrute de su conexion Compartida...."


Ya configurado creado el script, es necesario darle permisos de ejecución a este con un chmod +x .

Teniendo los permisos, configuraremos (manualmente) la dirección Ip de nuestra interfaz cableada, para ello editamos el archivo /etc/network/interfaces, especificamente, el apartado que haga referencia a nuestra interfaz Lan el cual dira algo asi:

auto ethX
iface ethX inet dhcp

Donde la x representa un numero el cual se le ha asignado a la interfaz (se puede tener mas de una).

Este apartado lo cambiaremos por algo así:

auto eth0
iface eth0 inet static
address 192.168.100.1
netmask 255.255.255.0

guardamos los cambios y reiniciamos la red...

# invoke-rc.d networking restart

Ejecutamos el escript:

./compartirInternet.sh

Cliente:

Configurar el cliente es tarea mas sencilla, simplemente debemos editar lo referente a la interfaz de red Lan... Editamos el archivo /etc/network/interfaces, especificamente, el apartado que haga referencia a nuestra interfaz Lan el cual dira algo asi:

auto ethX
iface ethX inet dhcp

Donde la x representa un numero el cual se le ha asignado a la interfaz (se puede tener mas de una).

Este apartado lo cambiaremos por algo así:

auto eth0
iface eth0 inet static
address 192.168.100.2
netmask 255.255.255.0
gateway 192.168.100.1


guardamos los cambios y reiniciamos la red...

# invoke-rc.d networking restart

Listo, ya hemos compartido nuestra conexión a internet... Alternativamente, es posible profundizar en el tema y reducir pasos instalando un servidos DNS en nuestro equipo...

Usando el raton en consola

Retomando el uso de mi blog para documentar, hoy traigo un paquete útil para todos aquellos que viven mas tiempo en la consola que en la interfaz gráfica... Si bien es cierto, que mucho se puede hacer usando atajos por teclado no es menos cierto, que de cuando en vez nos viene en falta el uso del ratón y para esto contamos con GPM

GPM (general purpose mouse o ratón de propósito general) es un paquete (que se encuentra en varias distros) que nos permite hacer uso del ratón en las tty's es decir, podemos utilizar el ratón en consola con todas las comodidades que implica; incluso,  no sólo proporciona soporte para cortar y pegar, sino que su librería se usa en varios programas (como links, aumix, ncurses, Midnight Commander -mc) para proporcionar soporte de ratón a la aplicación.

Lo que debemos hacer es sencillo; lo primero es instalarlo para ello:

# aptitude install gpm


terminada la instalación ya esta, basta con mover el raton y listo... Habemmus mouse !!!


En caso que falle, viene util realizar una reconfiguracion del mouse:


# dpkg-reconfigure gpm

martes, 17 de agosto de 2010

Bam digitel en Slackware 13.1

Aunque crei que esto seria algo realmente mas dificíl, debo reconocer que montar el soporte para este dispositivo en Slack ha resultado super sencillo, ha sido cosa simplemente de que instale Wvdial y listo.

Existen, según he podido ver muchas maneras de instalar el paquete, pero yo en lo personal he seguido una receta muy sencilla.

Lo primero que he hecho es buscar la fuente del paquete ya complida, y la encontre en  repository.slacky.eu

He de destacar, que no encontre el paquete compilado para mi versión especifica por lo que decidi descargar el de la versión anterior (este).

Ya descargado el paquete, la instalación fue sencilla, simplemente ejecutar:

# installpkg wvdial-1.61-i686-1slacky.txz

Ahora bien, sucede que también es necesario que instalemos un par de librerias, para ello (en mi caso) simplemente es cosa de ir a SlackBuilds.org y descargar wvstreams para nuestra versión de Slackware (aca para 13.1).

Igual que el paso anterior, ya descargado el paquete simplemente ejecutamos:

# installpkg wvstreams-4.6.1-i486-2bj.txz

Instalados los paquetes es momento de configurar, para ello, conectamos el Modem y ejecutamos:

# wvdialconf

Terminada la configuración, nos toca ahora montar lo correspondiente a la configuración del proveedor, para ello ejecutamos:

# nano /etc/wvdial.conf

El archivo para digitel queda asi:


Ya teniendo el archivo es hora de marcar:

#wvdial

Listo, ya tenemos conexión en nuestro Slack.... Enjoy


viernes, 13 de agosto de 2010

Configurando Usuarios (post Instalacion Slackware)

Ya terminada la instalación de Slackware, siguiente que hay que hacer es crear los usuarios, a fin de cuentas, usar la cuenta root para entorno gráfico es lo peor que se puede hacer (con esto anulamos toda la seguridad del sistema).

Crear una vez terminada la instalacion los usuarios es un proceso sencillo, solo debemos ejecutar un par de comandos y responder las preguntas.

Lo que debemos hacer en entrar en la consola, hacer login como Root y ejecutar:

# groupadd NombreGrupo

Con esto indicamos al sistema la creación de un nuevo grupo, este nos respondera, solicitando alguna información para el grupo y listo. Habemus Grupo...

Ahora, es momento de crear el usurio, para ello, aun en la Shell y como Root ejecutamos:

# adduser NobreUsuario

Nuevamente respondemos las preguntas y ya... esta listo, ahora si podemos salir de la cuenta root, entrar como el nuevo usuario e invocar nuestras X's