Mostrando entradas con la etiqueta Scripts. Mostrar todas las entradas
Mostrando entradas con la etiqueta Scripts. Mostrar todas las entradas

lunes, 26 de septiembre de 2011

Squid Transparente + cache

Como parte de los articulos, que tenia pendiente escribir y que he tocado en mis 2 últimos cursos, llego el momento de al fin documentar la instalación básica de un proxy transparente en squid y con chache para reducir un poco nuestras consultas...

El proceso, que ahora documento, lo aplique en Fedora 15 (por motivos de trabajo migre mi servidor a esta plataforma) pero aplica a otras distribuciones en general.

Conocido es dentro de la comunidad, que el archivo de configuración de Squid, es uno de los mas documentados... En su gran cantidad de lineas, se hallan todas las explicaciones que nos indican que podemos hacer -Debo aclarar que para mi sorpresa RHEL cambio este archivo y presenta ahora una versión muy corta- para configurar nuestro proxy.

Ahora, la realidad es que aunque tiene un montón de lineas, se puede tener funcionando un squid con modificar solamente un par de parámetros...

El primer paso sencillamente es instalarlo, para ello en distros .Deb ejecutamos:

# aptitude install bind

Mientras que en otras RHEL:

# yum -y install bind

Ya instalado lo que tenemos que hacer es modificar los parámetros básicos en el archivo de configuración el cual se encuentra en /etc/squid/squid.conf

Dentro de este archivo, basicamente, lo que debemos hacer es:

  • Agregar el la parte de ACL una entrada para nuestra red local; la linea queda algo como esto: acl redcurso1 src 192.168.2.0/24
  • Agregar una regla para permitir la salida de nuestra red a internet, para ello, en el segmento de reglas del archivo agregamos algo así: http_access allow redcurso1
  • Ubicamos ahora, la configuración del puerto que usara squid, dejando la linea así: http_port 192.168.2.1:3128 transparent
  • Agregamos el nombre del host: visible_hostname none
  • Descomentamos y adaptamos la linea para el cache: cache_dir ufs /var/spool/squid 100 16 256
En una versión resumida (Sacada de mi configuración en Fedora), el archivo queda asi:

#
# Recommended minimum configuration:
#
acl manager proto cache_object
acl localhost src 127.0.0.1/32
acl localhost src ::1/128
acl to_localhost dst 127.0.0.0/8 0.0.0.0/32
acl to_localhost dst ::1/128

# Example rule allowing access from your local networks.
# Adapt to list your (internal) IP networks from where browsing
# should be allowed
acl localnet src 10.0.0.0/8    # RFC1918 possible internal network
acl localnet src 172.16.0.0/12    # RFC1918 possible internal network
acl localnet src 192.168.0.0/16    # RFC1918 possible internal network
acl localnet src fc00::/7   # RFC 4193 local private network range
acl localnet src fe80::/10  # RFC 4291 link-local (directly plugged) machines

acl SSL_ports port 443
acl Safe_ports port 80        # http
acl Safe_ports port 21        # ftp
acl Safe_ports port 443        # https
acl Safe_ports port 70        # gopher
acl Safe_ports port 210        # wais
acl Safe_ports port 1025-65535    # unregistered ports
acl Safe_ports port 280        # http-mgmt
acl Safe_ports port 488        # gss-http
acl Safe_ports port 591        # filemaker
acl Safe_ports port 777        # multiling http
acl CONNECT method CONNECT
acl redcurso1 src 192.168.2.0/24

#
# Recommended minimum Access Permission configuration:
#
# Only allow cachemgr access from localhost
http_access allow manager localhost
http_access deny manager

# Deny requests to certain unsafe ports
http_access deny !Safe_ports

# Deny CONNECT to other than secure SSL ports
http_access deny CONNECT !SSL_ports

# We strongly recommend the following be uncommented to protect innocent
# web applications running on the proxy server who think the only
# one who can access services on "localhost" is a local user
#http_access deny to_localhost

#
# INSERT YOUR OWN RULE(S) HERE TO ALLOW ACCESS FROM YOUR CLIENTS
#
http_access allow redcurso1

# Example rule allowing access from your local networks.
# Adapt localnet in the ACL section to list your (internal) IP networks
# from where browsing should be allowed
http_access allow localnet
http_access allow localhost

# And finally deny all other access to this proxy
http_access deny all

# Squid normally listens to port 3128
http_port 192.168.2.1:3128 transparent

# We recommend you to use at least the following line.
hierarchy_stoplist cgi-bin ?

# Uncomment and adjust the following to add a disk cache directory.

cache_dir ufs /var/spool/squid 100 16 256

# Leave coredumps in the first cache dir
coredump_dir /var/spool/squid

# Add any of your own refresh_pattern entries above these.
refresh_pattern ^ftp:        1440    20%    10080
refresh_pattern ^gopher:    1440    0%    1440
refresh_pattern -i (/cgi-bin/|\?) 0    0%    0
refresh_pattern .        0    20%    4320
visible_hostname none


Como hemos definido un proxy transparente, es necesario aplicar las correspondientes reglas de iptables, para ello, lo que haremos sera crear un pequeño scrip como el que sigue:

#!/bin/sh

# eth0 = internet
# eth2 = red Local

#----Limpiamos todas las reglas
iptables -F
iptables -X
iptables -Z
iptables -t nat -F
#----Damos inet a la LAN
iptables -t nat -A POSTROUTING -s 192.168.2.0/24 -o eth0 -j MASQUERADE
echo 1 > /proc/sys/net/ipv4/ip_forward
#----Politicas por defecto ACCEPT
iptables -P OUTPUT ACCEPT
iptables -P INPUT ACCEPT
iptables -P FORWARD ACCEPT

#Proxy transparente
iptables -t nat -A PREROUTING -i eth2 -p tcp --dport 80 -j REDIRECT --to-port 3128

Ejecutamos, el scrip y reiniciamos bind y listo.... A disfrutar de nuestro nuevo proxy...

martes, 22 de diciembre de 2009

Bash script - Introducción-

.... Correr los mismos comandos siempre ..., ... Ejecutar las mismas rutinas para sincronizar ...., en fin hacer esas tareas ciclicas - tediosas que siempre nos toca hacer, que ya matan cuando toca hacerlas....

Gnu Linux es un mundo de posibilidades, he inspirados en la visión hacker, de optimizar las tareas tediosas, esas que no nos gusta hacer pero que nada, tienen que hacerse existen los bash script.



Los script's hacen fácil la vida, permitiendo resumir múltiples tareas rutinarias y ahorrandonos de tener que ejecutar muchos comandos...

Aunque suenan complicados, en realidad son a sencillos lo que también son a útiles....


Vasta de palabras... Los que nos toca;

Los  script's siempre se inician con el siguiente identificador:


#!/bin/bash

Este encabezado, va siempre antes de cualquier otra linea...


Nuestro primer script


Honrando todos los libros, manuales y otros similares dedicados a iniciar a las personas a la programación, vamos a crear el famoso "hola mundo"....


1.- Iniciamos nuestro editor;


$ nano holamundo



2.- Copiamos en el archivo;


#!/bin/bash

echo "Hola Mundo"


3.- Guardamos y cerramos;


Ctrl o
Ctrl x


4.- Damos los permisos;


chmod +x holamundo

5.- Ejecutamos;


./holamundo


Mas alla -Intro-


Esto, es lo mas sencillo que podemos hacer con un script.... Los bash script, soportan estructuras de programación como:


if...else
while
for
echo
sleep
case

Y pueden ayudarnos a ejecutar (como ya di a entender) comandos en la consola de GNU Linux.


...


Hablar todo de script's en un post es poco, continuare dando algunos ejemplos y mostrando script's mas complicados en siguientes partes de este post....